关于WordPress中代码高亮插件SyntaxHighlighter所支持语言的说明

SyntaxHighlighter是应用在WordPress中的代码高亮插件,当我们在WordPress中编写文章时,使用它可以让我们安全地在文章中插入程序代码,并可以使代码高亮格式化显示,以下列出该插件所支持的代码类型:

actionscript3
bash
clojure
coldfusion
cpp
csharp
css
delphi
erlang
fsharp
diff
groovy
htmlscript
javascript
java
javafx
matlab(只支持关键字)
objc
perl
php
text(默认)
powershell
python
r
ruby
scala
sql
vb
xml

更多信息请参阅:Posting Source Code — Support — WordPress.com

发表评论